[NEWSboard IBMi Forum]
  1. #1
    Registriert seit
    Dec 2009
    Beiträge
    289

    Problem beim Copy vom IFS auf einen Windows Share

    Hallo.Folgendes ProblemIn einem CL-Programm wird folgendes gemacht:STRTCPSVR SERVER(*NETSVR) MKDIR DIR('/qntc/mydir') DTAAUT(*RW) OBJAUT(*ALL)Aus einem anderen CL wird dann folgender Befehl ausgeführt:COPY OBJ(&USRPFAD) TODIR(&DMSPDF)In den variablen sind die Quelle und das Ziel richtig definiert.Mit meinem i-Series User funktioniert es. Bei meinem Kollegen, welcher mehr Berechtigungen als ich habe, kommt folgende Fehlermeldung:CPDB053Error Class 1, Error code 5 wir haben jetzt schon alles mögliche probiert und kommen nicht hin.Hat vielleicht jemand eine geniale Idee?Danke im Voraus
    Andreas
    Ein AS/400 Dinosaurier since 1989

  2. #2
    Registriert seit
    Feb 2001
    Beiträge
    18.031
    Das Problem ist immer die Anmeldung.
    Da es keinen Anmeldedialog gibt, muss der ausführende User mit Kennwort als lokaler User auf dem Ziel-Windows registriert sein.
    Das hast du für dich wahrscheinlich mal so eingerichtet.

    Die Funktion "adopted authority", also Programm läuft unter *OWNER, wird im IFS grundsätzlich nicht unterstützt.
    Dienstleistungen? Die gibt es hier: http://www.fuerchau.de
    Das Excel-AddIn: http://www.fuerchau.de/software/upload400.htm
    BI? Da war doch noch was: http://www.ftsolutions.de

  3. #3
    Registriert seit
    Dec 2009
    Beiträge
    289
    Also den Unterschied zwischen meinem Kollegen und mir haben wir jetzt gefunden.
    Bei uns erfolgt die Anmeldung mittels KERBEROS. Wenn das AD-Password geändert wird, so erfolgt das automatisch auch im KERBEROS. Das lokale AS400 Password bleibt aber das alte. Bei mir funktioniert es deshalb, weil ich mein Netzwerk-Password mit meinen AS400 Passwörtern selber synchronisiere. Anscheinend verwendet der copy aus den Windows share das lokale Password. Und das ist jetzt ein Problem, denn unser Anwender machen sicher kein chgpwd auf der AS400.

    Hat vielleicht irgendjemand dafür eine Lösung?
    LG
    Andreas
    Ein AS/400 Dinosaurier since 1989

  4. #4
    Registriert seit
    Feb 2001
    Beiträge
    18.031
    Das Stichwort hierzu lautet "Single Signon". Dies schließt die Kennwortsynchronisiation mit ein.
    Voraussetzung ist dazu aber wohl PWDLVL 2 (langes Kennwort, casesensitive).
    Da du ja schon Kerberos hast, sollte es damit auch gehen.
    Dienstleistungen? Die gibt es hier: http://www.fuerchau.de
    Das Excel-AddIn: http://www.fuerchau.de/software/upload400.htm
    BI? Da war doch noch was: http://www.ftsolutions.de

  5. #5
    Registriert seit
    Dec 2009
    Beiträge
    289
    Hallo,
    das funktioniert bei uns aber nicht sauber, da nicht die AS400 das führende System ist und wenn das lokale Passwort vom Novell abweicht, geht das wieder nicht. Wir müssen da noch etwas forschen, wie ich das lokale mit dem Novell Passwort synchronisiere.
    Andreas
    Ein AS/400 Dinosaurier since 1989

  6. #6
    Registriert seit
    Feb 2001
    Beiträge
    18.031
    Dienstleistungen? Die gibt es hier: http://www.fuerchau.de
    Das Excel-AddIn: http://www.fuerchau.de/software/upload400.htm
    BI? Da war doch noch was: http://www.ftsolutions.de

  7. #7
    Registriert seit
    Dec 2009
    Beiträge
    289
    Danke für den Hinweis, werde mir das mit meinem Kollegen mal anschauen
    Andreas
    Ein AS/400 Dinosaurier since 1989

  8. #8
    Registriert seit
    May 2002
    Beiträge
    2.619
    welches Release betrifft es denn ?

  9. #9
    Registriert seit
    Dec 2009
    Beiträge
    289
    Wir haben 7.3 mit den letzten PTF's
    Andreas
    Ein AS/400 Dinosaurier since 1989

  10. #10
    Registriert seit
    May 2002
    Beiträge
    2.619
    auch dieses ? Dies ist ein 1000 er Ptf

    kommt von -> Link

  11. #11
    Registriert seit
    Dec 2009
    Beiträge
    289
    Das fehlt uns noch. Da werde ich mal meinen Opis ein wenig Dampf machen. Danke schön für den Link.
    Andreas
    Ein AS/400 Dinosaurier since 1989

Ähnliche Themen

  1. Windows Share Freigabe in CL
    Von Hanuta im Forum IBM i Hauptforum
    Antworten: 3
    Letzter Beitrag: 21-12-17, 09:34
  2. Problem beim Aufruf wsdl2ws.sh
    Von svit im Forum NEWSboard Programmierung
    Antworten: 5
    Letzter Beitrag: 23-01-17, 11:27
  3. Problem beim CPYTOIMPF
    Von Paul_Hofmann im Forum NEWSboard Programmierung
    Antworten: 4
    Letzter Beitrag: 23-09-15, 12:41
  4. Problem beim Laden von PTF SF65630
    Von Kent im Forum IBM i Hauptforum
    Antworten: 0
    Letzter Beitrag: 15-11-01, 10:59
  5. Problem beim Autostart von Client Access Druckersessions
    Von Rukober im Forum NEWSboard Drucker
    Antworten: 4
    Letzter Beitrag: 17-09-01, 08:58

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •